HeavyJob Performance Issues

Incident Report for Brayman Enterprise

Resolved

HeavyJob should now be operating at normal capacity
Posted Dec 02, 2025 - 11:23 EST

Investigating

We have had several reports of issues logging into HeavyJob and performance being low. We are aware and investigating the cause.
Posted Dec 02, 2025 - 09:21 EST
This incident affected: HCSS (HCSS - HeavyJob).