The Viewpoint upgrade is completed. Please launch your client and allow it to update. Sometimes the box to click OK is hidden behind the vista window so please check on that. You will need to launch the vista application twice to upgrade. Please email helpdesk@brayman.com with any issues.
Posted Oct 16, 2025 - 06:05 EDT
Scheduled
We will be upgrading the Viewpoint Software. Access will be unavailable during the upgrade.
Posted Oct 08, 2025 - 08:06 EDT
This scheduled maintenance affected: Viewpoint (Viewpoint VISTA).