Phone system outage

Incident Report for Brayman Enterprise

Resolved

Phone system services have been restored.
Posted Nov 26, 2025 - 12:36 EST

Investigating

Currently our local router is not connecting to Webex which is causing connectivity issues. We are investigating why this is happening.
Posted Nov 26, 2025 - 09:10 EST
This incident affected: Networking/Phone (Corporate Phone System).