Email Delivery Delays

Incident Report for Brayman Enterprise

Resolved

Proofpoint has let us know emails should be flowing smoothly now. We will continue to monitor
Posted Jul 28, 2026 - 12:33 EDT

Investigating

We have received some reports of email being slow to deliver. Upon investigating, we are seeing some latency with the email filtering system. If you are expecting time-sensitive emails (like confirmation codes), it's possible they may expire. Otherwise, please anticipate delays of 5-10 minutes. We are working with the provider to isolate the issue.
Posted Jul 28, 2026 - 12:05 EDT
This incident affected: Exchange Email.